Very Beta Chat Idea – Graduated!

HomeForumsVery Beta Chat Idea – Graduated!

This topic has 1 voice, contains 53 replies, and was last updated by 7 years ago.

Viewing 15 posts - 1 through 15 (of 54 total)
Author Posts
Author Posts
December 14, 2007 at 10:49 pm #353125
Avatar of Schlaeps
Schlaeps

This is one of those things I’m not sure would make such a great feature for the general public, but I was toying with the idea of redoing the current chat to create a newer, less buggy one.

The problem is I don’t know how hard this’ll be on the server, so it might never see the light of day.

But in any case, I’d love to get feed back.

I’d pretty basic right now.

Anyone can set the chat topic.
//, /me, and /clear work (// is only available to me atm).

http://www.brickfilms.com/chatbeta/

Happy testing. :)

-Schlaeps

December 14, 2007 at 11:20 pm #353133
Avatar of Lord_Of_The_LEGO
Lord_Of_The_LEGO

Problem #1: I can’t type anything.

And that’s as far as I got.

December 15, 2007 at 12:53 am #353166
Avatar of Schlaeps
Schlaeps

Did it show anything in the main box?

December 15, 2007 at 1:28 am #353179
Avatar of Lechnology
Lechnology

The textfield is inaccessible. Thus, we’re unable to type

December 15, 2007 at 1:43 am #353184
Avatar of RevMen
RevMen

The text box is greyed out and non clickable.

I would recommend not having a person’s profile open when you click their name. People will be expecting things like private chat or blocking or that sort of thing.

December 15, 2007 at 2:20 am #353194
Avatar of Krick
Krick

I also cannot type anything in the latest version of firefox.

December 15, 2007 at 2:20 am #353195
Avatar of Schlaeps
Schlaeps

PMing will come in the future, I just wanted them to actually do something for the moment.

Also, does nothing show up in the top box? I’ve set it up to automatically enable the text input when the script starts up, but if nothing shows up in the box that’s a problem.

December 15, 2007 at 2:27 am #353197
Avatar of Krick
Krick

All I get in the top box is, “Welcome to the Brickfilms Chat!“. Is that what you meant?

Edit: And also Schlaeps’ and Trill’s text.

December 15, 2007 at 2:38 am #353200
Avatar of Schlaeps
Schlaeps

Alright, should work now.

December 15, 2007 at 7:17 am #353253
Avatar of Lord_Of_The_LEGO
Lord_Of_The_LEGO

Was able to type now and change the topic. Looks pretty good, though I am annoyed by test appearance delay and I’m not sure if I like or dislike the text fading and coming in from the left all Web 2.0 style.

EDIT: Ah, I see, unchecking Beautify seems to disable the swishy movement stuff.

December 15, 2007 at 12:53 pm #353298
Avatar of LegosJedi
LegosJedi

Looks good, Schlaeps. Better than the old one, IMO. Though I noticed that when I had a chat window opened, then opened another one, then closed that one, The message wasn’t completely there.

's chat has timed out. has left the chat.
LegosJedi has left the chat

Apparently, my username wasn’t filled in on the first line. And then, after I closed that second window, I couldn’t send chat messages in the first one again. Not sure if that’s supposed to happen or not.

I’ll do more testing, along with *trying* to do some SQL injections and stuff, to make sure it’s all good. ;)

EDIT: I noticed also that that first line will just pop in every so often.

December 15, 2007 at 7:25 pm #353391
Avatar of Schlaeps
Schlaeps

Yeah, it’s not very good with multiple windows yet.

I thought I fixed that weird missing username bug last night… oh well, should be fixed now.

Also, I’ve add some minor sound support (disabled by default and definitely not the final sounds) as well as fixed the mod issues so that now only mods can have // and /topic.

December 15, 2007 at 10:08 pm #353449
Avatar of LegosJedi
LegosJedi

I just noticed that there was a user who was called ‘Anonymous’, but there was no one else in the chat with me.

Anonymous has left the chat

Who’s that?

December 16, 2007 at 2:43 am #353589
Avatar of An Old Ore
An Old Ore

It loads up nice and fast.

I’m not a big fan of 2.0 “swishy” effects so I’m glad that their is an ‘unbeautify’ option.

There is a noticeable delay in typing and text appearing. I was testing typing 1 then enter, 2 then enter and on through the numbers to see how it handled fast messaging and it would come up as:

123
4567
891
2
3456
and so on, rather than:
1
2
3
4
5
6
etc

I notice that the /away isn’t available yet, didn’t try the other ‘secret’ codes of the old chat since it seems unlikely that they would be implemented in this version.

Pressing ‘reload’ / refresh loses all text – never tried that with the old chat by I can’t see that being a bug – it’d be the same as logging out and logging back in, right?

Tried smilieys, which obviously aren’t installed, but typing :x crashed the system, needed to refresh. The page stayed open, but no text would be sent to the server (pressing enter did nothing).

Tried to force a crash with odd characters:
? = okay
& = okay
web address = okay (used http://www.google.com and http://www.brickfilms.com/chatbeta/)
* / – $ @ ! = all okay

Any text with a percentage sign (%) does not come up. Entering % on it’s own will not display and entering “I have 50% left” does not come up either – but it does not crash.

December 16, 2007 at 8:22 pm #353796
Avatar of LegosJedi
LegosJedi

So, since the percent sign isn’t coming up, I’m assuming that could either be to prevent SQL injections, or data is being sent in an ‘array’ that is separated by that.

Viewing 15 posts - 1 through 15 (of 54 total)

You must be logged in to reply to this topic.