Who wants to update Anasazi SMA?

Home Forums Brickfilming Forums Hardware and Software Who wants to update Anasazi SMA?

This topic contains 407 replies, has 1 voice, and was last updated by Profile photo of Prog Shooter Prog Shooter 5 years, 7 months ago.

Viewing 10 posts - 251 through 260 (of 384 total)
  • Author
    Posts
  • #301521
    Profile photo of Prog Shooter
    Prog Shooter
    Participant

    It’s still not working. I think I’m just going to wait for the .exe

    #301617
    Profile photo of polaking
    polaking
    Participant

    Can I help in this ‘project’? I am no Python coder but maybe If you want, I can package it into an installer for you (once you have compiled it to EXE).

    #301620
    Profile photo of Prog Shooter
    Prog Shooter
    Participant

    Compiling it has been the hardest part so far. If you can do that for us, you’ll be our new best friend :)

    #301625
    Profile photo of polaking
    polaking
    Participant

    Okay.. This might be the cause of problems during running the Python ‘script. I was trying my best to compile it but first I tried to run it so I installed Python and wxPython. I noticed after running through the command line I get this ‘error’:

    I am not too sure if this is meant to happen. So if this is a ‘bug’ please fix it.

    EDIT: Hmm.. after figuring out what PIL means, I managed to get a download link thanks to Google. Hopefully this will work.

    EDIT2: Okay, new error:

    Has anyone got an idea?

    #301646
    Profile photo of Amped
    Amped
    Participant

    Prog what Mr Polakin meant, was ONCE it has been compiled he will make an installer for it.

    #301647
    Profile photo of polaking
    polaking
    Participant

    Well I myself am going to try to compile it but please see my problem above.

    #301883
    Profile photo of Prog Shooter
    Prog Shooter
    Participant

    My wistfulness precedes me, Amped. I’m sorry.

    #301991
    Profile photo of Amped
    Amped
    Participant

    Okay, I fixed my last error, python 2.5 was needed, I installed wxPython for 2.5, but I get the same error Polaking got the first time. What is this PIL module?

    EDIT: Looks like im playing follow the leader, I downloaded PIL, and got the same error. Ill post my, though its the same because the screenshot Polaking posted is impossible to read. But when I ran the script, I window popped up without buttons or anything then dissapeared

    File “AnasaziFrameGrab.pyw”, line 278, in
    File “C:Python25Libsite-packageswx-2.8-msw-unicodewx_core.py”, line
    , in __init__
    self._BootstrapApp()
    File “C:Python25Libsite-packageswx-2.8-msw-unicodewx_core.py”, line
    , in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
    File “AnasaziFrameGrab.pyw”, line 208, in OnInit
    File “AnasaziFrameGrab.pyw”, line 168, in __init__
    File “AnasaziFrameGrab.pyw”, line 41, in __init__
    TypeError: ‘module’ object is not callable

    Has Polakings error returned the error and then printed the line that is in error? I checked mine against his and he has a few more lines in the error message, I checked the code in IDLE and those extra lines are the code corresponding to the lines the error mentioned. (if you can understand that)

    EDIT 2: Installed pyscho thinkin it might help, but still get same error
    EDIT 3: If anyone wants them, Pyscho Download
    PIL (windows only)

    #302007
    Profile photo of bluejeansummer
    bluejeansummer
    Participant

    Ok, I looked at the error, and I think I have a solution:

    Open up AnasaziFrameGrab.py in notepad, and go to line 41:
    After the word Image and before the parenthises (spellcheck), insert .open (notice the period).

    Also, Pysco is not nessisary (another spellcheck), but it may make it run faster (not that it does much good at this point).

    Just to clarify, compileing to exe is a completely different thing than just running the program. However, it is on my to-do list.

    — bluejeansummer

    #302011
    Profile photo of Mojestic Maffles
    Mojestic Maffles
    Participant

    @BJS & polaking-I’ve found something called py2exe. It does something like compiling. Also, for macs, there is something called py2app that does mac .app compiling.

    py2exe website: http://www.py2exe.org/

Viewing 10 posts - 251 through 260 (of 384 total)

You must be logged in to reply to this topic.